[poj 1018]Communication System(动态规划)

题目

Communication System

Time Limit: 1000MS
Memory Limit: 10000K

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with m_i (1 ≤ m_i ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1
2
3
4
1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

1
0.649

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest


解题思路

  • dp状态:$dp[i][j]$ 表示前 $i$ 个设备总带宽(即最小带宽)为 $j$ 时的最少价格
  • dp方程:设当前设备带宽为 $b$,价格为 $p$,则:
    当 $b \leq j$ 时,$dp[i][b] = min(dp[i][b], dp[i-1][j] + p)$
    当 $b > j$ 时,$dp[i][j] = min(dp[i][j], dp[i-1][j] + p)$
  • dp顺序:由dp方程可知,for i=1 to n, for j=1 to maxB(最大带宽) 即可
  • 边界条件:$dp[0][j] = 0, dp[i][j]=INF(i>0)$

时间复杂度 $O(\sum m \cdot maxB)$


Code

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
# include<cmath>
# include<cstdio>
# include<iostream>
# include<algorithm>

using namespace std;

const int INF = 1e9;

int CASES, n, m[105];

struct Device{
int band, price;
void init(){
band = price = 0;
}
}d[105][105];

int dp[105][1105]; // dp[i][j] 表示前 i 个设备达到 j 带宽(即最小带宽为 j)时的最少价格

int main(){
scanf("%d", &CASES);
while(CASES--){
scanf("%d", &n);
int maxB = 0;
for(int i = 1; i <= n; i++){
scanf("%d", &m[i]);
for(int j = 1; j <= m[i]; j++){
scanf("%d%d", &d[i][j].band, &d[i][j].price);
maxB = max(maxB, d[i][j].band);
}
}
for(int i = 0; i <= n; i++)
for(int j = 1; j <= maxB; j++)
dp[i][j] = i == 0 ? 0 : INF;
for(int i = 1; i <= n; i++){
for(int j = 1; j <= m[i]; j++){
for(int k = 1; k <= maxB; k++){
if(k < d[i][j].band)
dp[i][k] = min(dp[i][k], dp[i-1][k] + d[i][j].price);
else
dp[i][d[i][j].band] = min(dp[i][d[i][j].band], dp[i-1][k] + d[i][j].price);
}
}
}
double ans = 0;
for(int j = 1; j <= maxB; j++)
ans = max(ans, (double)j / dp[n][j]);
printf("%.3f\n", ans);
}
return 0;
}